Jump to content

Hello From A New Member in Sheffield.


Tykebike
 Share

Recommended Posts

I'm new to the forum keen to fire up my know how on Kamado cooking. Having had a 3 burner Outback for years I was intrigued by the Kamado style of BBQing so I eventually managed to order an Aldi one after seeing Tom over at BBQ life uk on YouTube. I'm awaiting delivery (a of 1st July).

There is one thing that I find frustrating on the forum and this is probably due to my inexperience but when I search for a topic e.g. Charcoal and find a number of posts when I click on one I cannot see anything. This is not an  isolated incident or faulty link and I am logged in to my account.  I tried accessing support but it seems that I cannot do so - why is this as no explanation is given which doesn't seem like support at all.

Hope someone can point me in the right direction.

Link to comment
Share on other sites

Hi and :welcome:, I've had my AK for a couple of months and it's been great to use. I have the smaller one too from a couple of years ago. 

I have no idea why you aren't getting to see posts. The search is working for me, But I'm not affiliated with the site. Hopefully you get it sorted. 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...